x
login Signup

Git plugin unable to connect using ssh key

I am trying to make the git plugin work with my ssh key but am receiving the following error:

Error: Return (128) from RunCommand. at (eval 32) line 363. Cloning into '/opt/electriccloud/electriccommander/workspace/TestGitConfig_13/licenseminer'... Warning: Permanently added the RSA host key for IP address '< address>>' to the list of known hosts. Permission denied (publickey). fatal: Could not read from remote repository.

Please make sure you have the correct access rights and the repository exists.

Here's the background info: 1) I have successfully been using the Git plugin for several years now over https and username/password 2) plugin is version 3.7.3.29 3) Flow is version 8.2 4) OS is ubuntu 16.04 5) I have created the the ssh public/private keys and installed them under the ~/.ssh directory for agent user 6) As the agent user on the same resource as the procedure runs, I can successfully run a git clone by cutting and pasting the same command that is found in the plugin output log. 7) I created a ECSM configuration with the private key content pasted into the appropriate field and have configured the procedure to use that configuration.

I know that the plugin doesn't use the ~/.ssh directory but instead writes a ssh wrapper file in the /tmp directory using the config content. I just needed to validate that the key worked. My concern is that the ssh wrapper that is being generated is not working properly....

Has anyone else run into this? Are there any environment settings or character escaping issues that prevent the private key from being written out correctly?

avatar image By david 131 asked Aug 03 at 08:41 PM
more ▼
(comments are locked)
10|750 characters needed characters left

1 answer: sort voted first

Hi, David!

First of all, I am not sure, that it will work using https repository url with private key. Today we've verified your case and confirmed that it works.

To make it working, please, make sure that: 1) Your private key is pasted as is, like:

 -----BEGIN RSA PRIVATE KEY-----
 PRIVATE KEY CONTENT
 -----END RSA PRIVATE KEY-----

2) Your repository is in ssh format, for example (using github):

 git@github.com:electric-cloud/EC-JBoss

Then it should work.

avatar image By dshamatr 0 answered Aug 09 at 04:33 PM
more ▼
(comments are locked)
10|750 characters needed characters left
Your answer
toggle preview:

Up to 8 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.