x
login Signup

Flow Server does not start in CentOS

In commander-service.log we saw that commander wrapper process was not starting due to:

 STATUS | wrapper  | 2017/10/06 14:12:47.398 | Launching a JVM...
 INFO   | jvm 1    | 2017/10/06 14:12:47.699 | WrapperManager: Initializing...
 INFO   | jvm 1    | 2017/10/06 14:12:48.800 | WrapperManager Error: Failed to connect to the Wrapper at port 32,000. Cause: java.net.ConnectException: Connection refused (Connection refused)
 INFO   | jvm 1    | 2017/10/06 14:12:48.800 | WrapperManager Error: Exiting JVM...
 ERROR  | wrapper  | 2017/10/06 14:12:49.251 | JVM exited while loading the application.

The port 32000 was free on this CentOS box.

avatar image By hchu 30 asked May 24 at 10:50 PM
more ▼
(comments are locked)
10|750 characters needed characters left

1 answer: sort voted first

In some cases, it is necessary to control the range of ports that the Wrapper will use when choosing a port. The defaults were chosen to make it very unlikely that they would conflict with any well-known ports numbers (from 0 to 1023 generally assigned on most systems). If the default 32000-32999 range is causing problems, it can be changed using the wrapper.port.min and wrapper.port.max properties. If these are used, be sure to provide a large enough range to make it unlikely that all of the ports will be in use when the Wrapper attempts to start.

Example:

 wrapper.port.min=32000
 wrapper.port.max=32999

We used a different port range lower than 32000 by adding the below lines in the /conf/wrapper.conf and now the commander wrapper service started.

 wrapper.port.min=27000
 wrapper.port.max=27999

alt text

From the above screenshot, it is clear that Wrapper port 32000 was the only unavailable port on the box and the Tanuki JVM wrapper of the Flow service uses that port by default. By changing the above settings, the wrapper is able to use port 27000 and the Flow service can start.

Next when promoting an EC-Kubernetes plugin (this loads the Kubernetes Grapes library to the repository), we encountered the below error:

 Errors detected during execution of plugin's ec_setup script: Exit code 1: ERROR: Publish failure: Unexpected retrieval exception for repository '': 'https://zlt15178.vci.att.com:8200/artifacts/com.electriccloud/EC-Kubernetes-Grapes/1.0.0': AccessDenied: Access denied: [403]: {"error":{"where":"","message":"Access denied to artifact 'com.electriccloud:EC-Kubernetes-Grapes:1.0.0': java.net.ConnectException: Connection refused","details":"Access denied to artifact 'com.electriccloud:EC-Kubernetes-Grapes:1.0.0': java.net.ConnectException: Connection refused","code":"AccessDenied"}}

This was because the repository server local agent was not running due to the same port issue mentioned above. In the /conf/agent/wrapper.conf we added the below lines and were able to start the agent and pinged it from the Commander UI. Now, the plugin promotion worked.

 wrapper.port.min=27000
 wrapper.port.max=27999

wrapper.png (509.0 kB)
avatar image By hchu 30 answered May 24 at 10:56 PM
more ▼
(comments are locked)
10|750 characters needed characters left
Your answer
toggle preview:

Up to 8 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question


Topics:

x3

asked: May 24 at 10:50 PM

Seen: 14 times

Last Updated: May 24 at 10:56 PM

Related Questions