x
login Signup

Run job in Jenkins through ElectricFlow

I installed the Jenkins plugin in ElectricFlow. In addition I configured the Jenkins connection in order to access to my Jenkins server. I created the Job Configuration in order to build a job in my Jenkins server. When I press run job, its executes but I have the following error message:

 Getting last build number...
 
 Request:
 GET http://xxx.xxx.xxx.xxx:8080/job/Continuos%20Integration%20-%20Build/lastBuild/api/xml
 Authorization: Basic bm1vcmFlXXXXXXXXXXXXXXXXzNA==

 Last build number: 13
 Launching build...
 Request:
 POST http://xxx.xxx.xxx.xxx:8080/job/Continuos%20Integration%20-%20Build/build
 Authorization: Basic bm1vcmFlXXXXXXXXXXXXXXMTIzNA==
 
 Error: 403 No valid crumb was included in the request
 Waiting for new build number...
 (a cycle start)
 
 Request:
 GET http://XXX.XXX.XX.X:8080/job/Continuos%20Integration%20-%20Build/lastBuild/api/xml
 Authorization: Basic bm1XXXXXXXXXXXXIzNA==
 
 Finnally : Error: No new build number in 15 seconds

More over the build number is correct (13), this is the las build in Jenkins server.

How can I make this work?

avatar image By nimoraes 16 asked Apr 21, 2016 at 10:12 AM
more ▼
(comments are locked)
10|750 characters needed characters left

1 answer: sort voted first

Sounds like CSRF Protection is not supported by the Jenkins plugin so you may have hack the plugin which is Perl to get it supported. See more information at below link from StackOverflow.

http://stackoverflow.com/questions/28577551/disable-a-jenkins-job

avatar image By xiaogang wen 1k answered Apr 24, 2016 at 01:49 AM
more ▼
(comments are locked)
10|750 characters needed characters left
Your answer
toggle preview:

Up to 8 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.