x
login Signup

ElectricFlow agent x64 libxml error

I've tested ElectricFlow x64 6.0 agent and fell into an issue when I'm trying to use XML::Simple library from script:

 /opt/electriccloud/electriccommander/perl/bin/perl: relocation error: /opt/electriccloud/electriccommander/perl/lib/site_perl/5.8.8/i686-linux-thread-multi/auto/XML/LibXML/Common/../../../../../../../../../lib/libxml2.so.2: symbol gzopen64, version ZLIB_1.2.3.3 not defined in file libz.so.1 with link time reference

This looks like a bug.

Agent version: ElectricFlowAgent-x64-6.0.0.94562
OS: CentOS 6.6 64-bit

Workaround:
- copy library libxml2 from 5.4 agent/server
- install libxml2 (32bits) with OS tools (yum, apt-get) and copy it from your system libraries to %AGENT_HOME%/lib directory

avatar image By thunder 80 asked Aug 03, 2015 at 10:37 AM
more ▼
(comments are locked)
10|750 characters needed characters left

1 answer: sort voted first

This is a known issue.

I'm glad your workaround works. Mine is to copy:

 cp <installDir>apache/lib/libz.so.1 to <installDir>/lib


avatar image By lrochette 5.9k answered Aug 03, 2015 at 02:45 PM
more ▼
(comments are locked)
avatar image thunder Aug 04, 2015 at 06:25 AM

Thanks, Laurent, this also works. I just did not found any descriptions on this error on ask.electic-cloud.com

10|750 characters needed characters left
Your answer
toggle preview:

Up to 8 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.