x
login Signup

installing Electric Commander 5.2 - error after configure DB

I've been trying to install 5.2 (fresh installation) and end up with the following error in server.log after copying the mysql driver and adding the values to the DB configuration

What am I doing incorrectly? How do I correct this?

Thanks

 STATUS | wrapper  | 2014/11/13 19:52:15.617 | Launching a JVM...
 INFO   | jvm 1    | 2014/11/13 19:52:15.817 | WrapperManager: Initializing...
 INFO   | jvm 1    | 2014/11/13 19:52:16.018 | 2014-11-13 19:52:15.972:INFO:oejs.Server:jetty-8.1.14.v20131031-PATCH3
 INFO   | jvm 1    | 2014/11/13 19:52:16.019 | 2014-11-13 19:52:15.990:INFO:oejdp.ScanningAppProvider:Deployment monitor /app/electriccloud/electriccommander/server/wars at interval 1
 INFO   | jvm 1    | 2014/11/13 19:52:16.019 | 2014-11-13 19:52:15.995:INFO:oejd.DeploymentManager:Deployable added: /app/electriccloud/electriccommander/server/wars/commander-server.war
 INFO   | jvm 1    | 2014/11/13 19:52:19.021 | 2014-11-13 19:52:18.979:INFO:oejpw.PlusConfiguration:No Transaction manager found - if your webapp requires one, please configure one.
 INFO   | jvm 1    | 2014/11/13 19:52:26.533 | 2014-11-13 19:52:26.469:INFO:c.war:Spring WebApplicationInitializers detected on classpath: [com.electriccloud.commander.war.CommanderServerInitializer@76e4359f]
 INFO   | jvm 1    | 2014/11/13 19:52:28.035 | AsyncLogDispatcher-ASYNC_FILE starting
 INFO   | jvm 1    | 2014/11/13 19:52:28.135 | AsyncLogDispatcher-ASYNC_SETUP_FILE starting
 INFO   | jvm 1    | 2014/11/13 19:52:28.135 | AsyncLogDispatcher-ASYNC_EVENT_LOG starting
 INFO   | jvm 1    | 2014/11/13 19:52:28.235 | SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
 INFO   | jvm 1    | 2014/11/13 19:52:28.235 | SLF4J: Defaulting to no-operation (NOP) logger implementation
 INFO   | jvm 1    | 2014/11/13 19:52:28.235 | SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
 INFO   | jvm 1    | 2014/11/13 19:52:31.738 | 2014-11-13 19:52:31.722:INFO:c.war:Initializing Spring root WebApplicationContext
 INFO   | jvm 1    | 2014/11/13 19:52:31.839 | 2014-11-13 19:52:31.771:INFO:oejs.AbstractConnector:Started SelectChannelConnector@0.0.0.0:8000
 INFO   | jvm 1    | 2014/11/13 19:52:31.939 | 2014-11-13 19:52:31.869:INFO:oejus.SslContextFactory:Enabled Protocols [SSLv2Hello, SSLv3, TLSv1, TLSv1.1, TLSv1.2] of [SSLv2Hello, SSLv3, TLSv1, TLSv1.1, TLSv1.2]
 INFO   | jvm 1    | 2014/11/13 19:52:31.939 | 2014-11-13 19:52:31.873:INFO:oejs.AbstractConnector:Started SslSelectChannelConnector@0.0.0.0:8443
 INFO   | jvm 1    | 2014/11/13 19:52:52.862 | ElectricCommander services failed to start: InvalidSchema: Unable to validate the database schema: Missing column: num_id in commander50.ec_agent
 INFO   | jvm 1    | 2014/11/13 19:54:19.138 | 2014-11-13 19:54:19.121:WARN:oejs.ServletHandler:/commanderRequest
 INFO   | jvm 1    | 2014/11/13 19:54:19.139 | java.lang.IllegalStateException: Can't find bean: BeanSupplier xmlResponseHandlerSupplier. Did you omit the 'm_' field name prefix?
 INFO   | jvm 1    | 2014/11/13 19:54:19.139 |     at com.electriccloud.util.LazywiredPostProcessor$LazywiredHandler.loadTargetBean(LazywiredPostProcessor.java:1208)


avatar image By mlucia 17 asked Nov 13, 2014 at 03:29 PM
more ▼
(comments are locked)
10|750 characters needed characters left

1 answer: sort voted first

I'm going to bet that this might be a manifestation of a missing "commander_upgrade" database, which it seems that Commander 5.x wants to have created as well. It's worth a try to create that database and see if that resolves this issue.

So, first ensure that the commander server processes are all shutdown. Then go back to the mysql utility, drop the commander database, and create it again (to ensure it's clean), then create the commander_upgrade database as well. Here's the magical mysql incantation I use for all fresh Comamnder 5.x installs. Use a better password than the one I use below.

 mysql -u root -p
 Enter password:
 Welcome to the MySQL monitor.  Commands end with ; or \g.
 Your MySQL connection id is 1
 Server version: 5.5.29-log MySQL Community Server (GPL)
 
 Copyright (c) 2000, 2012, Oracle and/or its affiliates. All rights reserved.
 
 Oracle is a registered trademark of Oracle Corporation and/or its
 affiliates. Other names may be trademarks of their respective owners.
 
 Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
 
 mysql> CREATE DATABASE commander;
 Query OK, 1 row affected (0.05 sec)
 
 mysql> GRANT ALL ON commander.* TO commander@localhost IDENTIFIED BY 'commander';
 Query OK, 0 rows affected (0.00 sec)
 
 mysql> CREATE DATABASE commander_upgrade;
 Query OK, 1 row affected (0.00 sec)
 
 mysql> GRANT ALL ON commander_upgrade.* TO commander@localhost IDENTIFIED BY 'commander';
 Query OK, 0 rows affected (0.00 sec)
 
 mysql> QUIT;
 Bye



Addendum: I also have run into issues with inappropriate mysql.ini settings -- here's the process I use for Commander usage. This is for mysql 5.5 -- if you are using something different, you may have to change some of the settings.

Start with the example "medium" my.ini shipped with mysql (my-medium.ini). Copy that to the correct place (details vary by operating system, and you don't say if you are running windows or linux).

You’ll need to make a few adjustments to the configuration file in order to make it suitable for ElectricCommander’s requirements:

 1.    Add the following lines to the configuration file, right after the line that reads “[mysqld]”:
   character_set_server = utf8
   max_connections = 200
   connect_timeout = 14400
 
 2.    Locate the two places in the configuration file where “max_allowed_packet” is defined, and increase the value to “1024M” for both instances:
   max_allowed_packet = 1024M
 
 3.    Locate the line that defines “log-bin”, and comment that line out:
   #log-bin=mysql-bin
 
 4.    Locate the line that defines “binlog_format”, and comment that line out:
   #binlog_format=mixed
 
 5.     (Optional, tuning for larger loads) Locate the line that defines “table_open_cache”, and increase the value from “64” to “512”:
   table_open_cache = 512
 
 6.    (Optional, tuning for larger loads) Add the following line to the configuration files, right after the line that reads “[mysqld]”:
   query_cache_size = 8M


avatar image By mike westerhof 2.8k answered Nov 14, 2014 at 07:06 AM
more ▼
(comments are locked)
10|750 characters needed characters left
Your answer
toggle preview:

Up to 8 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.